Hi all
I'm having a problem removing vertical gaps between images that only appears in Gmail App (Android 6.0). Works fine in all other clients

Note that <!--[if !gte mso 15]><!--></td><td valign="bottom"><!--<![endif]--> is a fix for Outlook and Gmail App still has the vertical line with </td><td>



    <table width="640" border="0" cellspacing="0" cellpadding="0" style="text-decoration:none;border-collapse:collapse;mso-table-lspace:0pt;mso-table-rspace:0pt;table-layout:fixed;border-spacing:0;table-layout:auto;border-collapse: collapse;mso-table-lspace: 0pt;mso-table-rspace: 0pt;text-decoration: none;table-layout: auto;border-spacing: 0; ">
        <tbody>
            <tr>
                <td>
                    <a target="_blank" href="http://www.....com/why-use-a-centrifugal-separator.html" style="color:#000000;cursor:pointer;text-decoration:none !important;color: #000000;cursor: pointer;text-decoration: none !important;"><img width="231" height="202" border="0" alt="Read more about keeping oil cleaner longer" src="http://www.....com/emailer/201709/images/keepoilcleanerlonger_100_231x202.jpg" style="-ms-interpolation-mode:bicubic;text-align:center;line-height:20px;width: 231px; height: 202px; display: block; margin: 0px; outline: none;text-decoration: none;-ms-interpolation-mode: bicubic;border: none;display: block;"></a>
                    <!--[if !gte mso 15]><!--></td><td valign="bottom"><!--<![endif]-->
                    <a target="_blank" href="http://www.....com/why-use-a-centrifugal-separator.html" style="color:#000000;cursor:pointer;text-decoration:none !important;color: #000000;cursor: pointer;text-decoration: none !important;"><img width="178" height="202" border="0" alt="Read more about reducing man service hours" src="http://www.....com/emailer/201709/images/reduceservicemanhours_100_178x202.jpg" style="-ms-interpolation-mode:bicubic;text-align:center;line-height:20px;width: 178px; height: 202px; display: block; margin: 0px; outline: none;text-decoration: none;-ms-interpolation-mode: bicubic;border: none;display: block;"></a>
                    <!--[if !gte mso 15]><!--></td><td valign="bottom"><!--<![endif]-->
                    <a target="_blank" href="http://www.....com/assets/web-and-email-a4-mp200-data-sheet-v08.pdf" style="color:#000000;cursor:pointer;text-decoration:none !important;color: #000000;cursor: pointer;text-decoration: none !important;"><img width="231" height="202" border="0" alt="Read more about adding to existing power units" src="http://www.....com/emailer/201709/images/addtoexistingpowerunits_100_231x202.jpg" style="-ms-interpolation-mode:bicubic;text-align:center;line-height:20px;width: 231px; height: 202px; display: block; margin: 0px; outline: none;text-decoration: none;-ms-interpolation-mode: bicubic;border: none;display: block;"></a>
                </td>
            </tr>
        </tbody>
    </table>