I have been having a terrible time getting Gmail Inbox to render my hero image properly. It is supposed to span the width of the email but it puts a 30px padding to the left and right if it is centered and 60px to the right if no alignment is specified. I have tried everything, including putting a background color (that does not show up anyhow) to fill in the white space that should not be there.

This is the code for the section I keep having issues with:

<table border="0" width="100%" style="min-width:100%;" cellpadding="0" cellspacing="0" bgcolor="#ffffff">
    <tr>
        <td width="100%" bgcolor="#ffffff" style="background-color: #ffffff; font-size: 14px; line-height: 20px; font-family: 'Trebuchet MS', Arial, Helvetica, sans-serif; color: #333; min-width:100%;">

        <!-- ### BEGIN CONTENT ### -->
        <a href="http://www.kellycodetectors.com/treasure-stories/?utm_source=email&utm_medium=HeroBANNER&utm_content=TreasureStories&utm_campaign=MSTRStoryRequest20151015&utm_term=%%OptinSource%%" target="_blank" xt="SPCLICK" name="HeroBANNER" style="color:#000000; font-weight:bold; text-decoration:none; font-family:Arial, Helvetica, sans-serif; font-size:10px; color:#212121; line-height:20px;"><img width="100%" class="bannerImg" src="http://www.kellycodetectors.com/newsletters/201502-StoryRequest/hero.jpg" alt="What have you found?" border="0" hspace="0" vspace="0" style="vertical-align:top; min-width:100%;"></a>
        <!-- ### END CONTENT ### -->

        </td>
    </tr>
</table>

Thank you for any help you can give me.