I need to render a multipart email with two attachments (an image and .ics file). The email renders perfect on iOS when I attach just the image file.

However when I add the .ics file the HTML gets stripped on iOS's native mail app.

    Subject: Test email
    Mime-Version: 1.0
    Content-Type: multipart/related;
    boundary="--==_mimepart_559a3a0b7f30b_bfdc8082dbf8688c";
    charset=UTF-8
    Content-Transfer-Encoding: 7bit


    ----==_mimepart_559a3a0b7f30b_bfdc8082dbf8688c
    Content-Type: multipart/alternative;
    boundary="--==_mimepart_559a3a0b7eff7_bfdc8082dbf867d5";
    charset=UTF-8
    Content-Transfer-Encoding: 7bit


    ----==_mimepart_559a3a0b7eff7_bfdc8082dbf867d5
    Content-Type: text/plain;
    charset=UTF-8
    Content-Transfer-Encoding: 7bit

    Plain text version of my mail is here

    ----==_mimepart_559a3a0b7eff7_bfdc8082dbf867d5
    Content-Type: text/html;
    charset=UTF-8
    Content-Transfer-Encoding: quoted-printable

    <!DOCTYPE html>
    <html lang=3D"en">---SNIP---</html>


    ----==_mimepart_559a3a0b7eff7_bfdc8082dbf867d5--

    ----==_mimepart_559a3a0b7f30b_bfdc8082dbf8688c
    Content-Type: text/calendar;
    charset=UTF-8
    Content-Transfer-Encoding: base64
    Content-Disposition: inline;
    filename=test.ics
    Content-ID: <559a3a0b7989d_bfdc8082dbf86661@lappie.local.mail>

    QkVHSU46VkNBTEVOREFSDQpWRVJTSU9OOjIuMA0KUFJPRElEOmljYWxlbmRh
    ci1ydWJ5DQpDQUxTQ0FMRTpHUkVHT1JJQU4NCkJFR0lOOlZFVkVOVA0KRFRT
    VEFNUDoyMDE1MDcwNlQwODE5MjNaDQpVSUQ6NTBkZmM4N3ctYTQ2ZS00ZmY4
    LTlmNWYtZDcxZjMwTGQyNDg2DQpEVFNUQVJUOjIwMTUwNzA2VDEwMTkyMw0K
    RFRFTkQ6MjAxNTA3MDZUMTExOTIzDQpDTEFTUzpQVUJMSUsNCk9SR0FOSVpF
    UjpURVJFTkENClNVTU1BUlk6VFJVTlNJVFMNCkVORDpWRVZFTlQNCkVORDpW
    Q0FMRU5EQVINCg==

    ----==_mimepart_559a3a0b7f30b_bfdc8082dbf8688c--

Any suggestions on how to change this behaviour are more than welcome as my head is hurting over this :)